Announcement

Collapse
No announcement yet.

Would like help setting up printer for maximum X & Y dimension prints

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Would like help setting up printer for maximum X & Y dimension prints

    I have been thinking for quite a while that it might be nice to print storage boxes for my active spools of filament. I found this on TV: https://www.thingiverse.com/thing:3016906, which is pretty close to what I was imagining.

    The problem is that it would require the entire width & length of my Ender 5's printbed. Normally, the Ender 5's maximum print area is set to 220x220 mm, even though the bed is actually 235x235. Cura seems to think the printbed needs a margin of at least 10mm from each edge, leading to a maximum print area of 200x200, which is just not enough to print a box that can hold the filament spools.

    I have been trying to figure out how to utilize more of the printbed. So far, after watching a Teaching Tech video, I was able to move the X axis end stop switch to get some more area, but not enough. I also have to figure out move the Y axis switch. I have an idea for a new mounting plate for the Y switch which should make it adjustable. Still, there seem to be limitations in the firmware, Cura, or both that are preventing me from getting even more area.

    After moving the X axis limit switch, I decided to print CHEP's bed level test. I got a weird result:

    Click image for larger version

Name:	_MG_3843web.jpg
Views:	295
Size:	1.10 MB
ID:	9756

    1st, let me say that I forgot to take a photo of this before removing the squares from the plate. I had to place them back on the plate as close to the way they printed as I could. That said, it is pretty close. The thing to note is that the outside square is off: the right-hand & top lines are too close to the next square. I don't know why this would be. At the time of printing, the squares were perfectly evenly spaced, except for those 2 lines.

    Anyone have any idea what's going on? Can anyone tell me how, or point me to a good guide on, maximizing the printbed area?

  • #2
    Originally posted by Ender5r View Post
    Can anyone tell me how, or point me to a good guide on, maximizing the printbed area?
    I did that for my AnetA8 last year for the same reason. I usually wasn't interested in the print size as usually my ABS parts are quite small, but for the GiantClock I needed bigger parts.

    First of all you need to setup the zero point of your build plate right inside the firmware. There is no way around. When I home the Anet the print head is not over the print area, but the printer sees that as 0/0 if the setting is wrong. There is X_MIN_POS and Y_MIN_POS, which is misleading a little. I have them set to -33mm (X) and -10mm (Y), which means 0/0 is now exact the front left corner of the build plate. All that was left was to get the bed size right, which is 220/220.

    So now when you define a 220x220 build plate in Cura, the zero point is on the build plate and not at the home position. All future prints are centered by default in Cura as well as on the printer.

    Just a small side note regarding Cura. When you define a brim of 5mm, Cura is rendering the 5mm outside frame of the print bed as unusable. This is because you cannot place a model inside the 5mm frame as the space is needed for the brim. Same for the raft "overhang". This can be a little confusing at first, but is quite logic.

    Comment


    • #3
      Plus the heating element under the bed doesn't go all the way to the edges of the bed.

      Comment


      • #4
        Originally posted by Larry View Post
        Plus the heating element under the bed doesn't go all the way to the edges of the bed.
        I'm aware of this, but I'm thinking that having the bed heated for a while will make it OK. After all, the bed is 3mm aluminum.

        Comment


        • #5
          Originally posted by Geit View Post

          I did that for my AnetA8 last year for the same reason. I usually wasn't interested in the print size as usually my ABS parts are quite small, but for the GiantClock I needed bigger parts.

          First of all you need to setup the zero point of your build plate right inside the firmware. There is no way around. When I home the Anet the print head is not over the print area, but the printer sees that as 0/0 if the setting is wrong. There is X_MIN_POS and Y_MIN_POS, which is misleading a little. I have them set to -33mm (X) and -10mm (Y), which means 0/0 is now exact the front left corner of the build plate. All that was left was to get the bed size right, which is 220/220.

          So now when you define a 220x220 build plate in Cura, the zero point is on the build plate and not at the home position. All future prints are centered by default in Cura as well as on the printer.

          Just a small side note regarding Cura. When you define a brim of 5mm, Cura is rendering the 5mm outside frame of the print bed as unusable. This is because you cannot place a model inside the 5mm frame as the space is needed for the brim. Same for the raft "overhang". This can be a little confusing at first, but is quite logic.
          So, if my bed is physically 235x235 can I set it to that in the firmware?

          Comment


          • #6
            Originally posted by Ender5r View Post

            So, if my bed is physically 235x235 can I set it to that in the firmware?
            Sure, you need to set X_BED_SIZE and Y_BED_SIZE as well as the mentioned X_MIN_POS and Y_MIN_POS in Configuration.h

            Comment

            Working...
            X