Announcement

Collapse
No announcement yet.

Octopi vs Ender3V2 layer information

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Octopi vs Ender3V2 layer information

    The other day I installed the "display progress pluginn" on my Octopi server (as suggested in one of DrVax's video's) and I just noticed that my octopi installation is always reporting to be on a layer, two ahead of what my Ender3 v2 says it is on. From what I can see, the first actual layer of my model is seen as layer 2 or 3 by Octopi depending on having a skirt printed or not (the spill-line and skirt) seem to be reported as separate layers by Octopi).

    I'm asking because I just tried out DrVax's multi-color print with one hotend video and am encountering a problem in that the layer Octopi stops on is alwasy reported 1 or 2 later than what I asked in Cura and and in 9 out of 10 prints the printer resumes one layer lower that what he is supposed to have stopped on thus leading to incorrect prints.

    Is this an error, normal functionality of Octopi or do I have to install some extra plugins or make some changes to my configuration (Ocotpi is only adjusted in those area's that have been talked about in the different DrVax video's)?

  • #2
    Originally posted by BESLO View Post
    Is this an error, normal functionality of Octopi or do I have to install some extra plugins or make some changes to my configuration (Ocotpi is only adjusted in those area's that have been talked about in the different DrVax video's)?
    I always use the "pause at height" plugin to change filament. In Cura preview the pause layer is exactly at the point shown. If e.g. you have letters on a place, I just slide the layers in preview until I found the last layer without text. The number on the layer slider is the value I use in the plugin. This always works for me.

    To display the layers/time while printing, there is also a plugin in Cura.

    I am not sure about the plugin in OctoPrint. It could be that Octo print is counting from 0 while Cura is counting from 1.

    Comment


    • #3
      The binary start option is an interesting 1, although it wouldn't account for being 2 or 3 layers out of sync.

      I agree with Geit about how to select which layer to stop at in order to change filament: use the same software you use to slice the model. It knows how the layers are set up. BTW, so far, I have only used the layer # option of Pause at Height post script.

      Comment


      • #4
        Originally posted by Ender5r View Post
        The binary start option is an interesting 1, although it wouldn't account for being 2 or 3 layers out of sync.

        I agree with Geit about how to select which layer to stop at in order to change filament: use the same software you use to slice the model. It knows how the layers are set up. BTW, so far, I have only used the layer # option of Pause at Height post script.
        I also use the "Pause at layer" option, as mentioned in DRVax's video in Cura. I set it to eg layer 5 but Octopi says it stops at 6 (or 7 when I have a skirt) but the layer printed before the pause is identical to the layer I selected in Cura so the pause is still at the correct moment, only Octopi keeps saying the layer numer is different. After I resume in Octopi most of the times the printing starts at a level one layer lower than the one it stopped at although the layer being printed is the correct one (so after a stop at 5 it tries to print 6 but at the wrong height).

        So I am wondering where the difference in layer # information between Octopi, the "display progress" plugin and the information I have in Cura comes from. I'm also wondering if that could be the cause of my resume after pause starting at an incorrect height.

        Comment


        • #5
          Sorry, your question is above my pay grade

          Comment


          • #6
            I found the problem: Cura is always restarting at the last layer after a pause although it should restart at the next layer. I now use Prusa and there the printing resumes at the right layer. Also the layer information reported by Ocotpi and the printer are the same.

            So I guess Cura is counting the waste line and skirt as layers too for PrisaSlicer this is on the same layer as the object being printed.

            And on top of that printing using Prusa is a lot faster and cleaner. I only had to lower my temperature to cope with the filament I am using.

            Comment


            • #7
              If only I could figure out how to organize profiles in PrusaSlicer, I would likely use it instead of Cura.

              Comment


              • #8
                Originally posted by Ender5r View Post
                If only I could figure out how to organize profiles in PrusaSlicer, I would likely use it instead of Cura.
                I was lucky in that there is a perfect profile for my Ender 3 v2 printer ready made in Prusa. I only needed to change the temps of the filament and the bed to go with my filament. I haven't looked into creating my own profiles yet. I will have to however since I want to also use PETG.

                Comment


                • #9
                  That's the issue: different profiles are needed for different filaments, sometimes even for different colors of the same make & type of filament. My experience is that PrusaSlicer's way of doing profiles is complicated & confusing. I absolutely do not want to have to keep changing the temperature, flow rate, & other parameters every time I load a different filament. There is simply too much chance of missing 1 or more parameters.

                  Comment


                  • #10
                    I agree one hundred percent. I have a tendency to change filaments without changing parameters because I'm lazy and impatient. But that hasn't been a problem lately because I still haven't put my printer back together.

                    Comment

                    Working...
                    X