Announcement

Collapse
No announcement yet.

BLTouch vs EZABL

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • BLTouch vs EZABL

    Currently have a Bltouch (genuine) and it shot craps today. Replaced the wiring and it still will not self test. It has been acting funky lately, failing when probing the bed. Considering I have to replace it I'm wondering if the EZABL is a better choice. Any experience here with both?

  • #2
    I have been considering the EZABL myself. According to [email protected], it can even work with glass beds, a fear of which led me to use BL Touch instead... now reconsidering.

    Comment


    • #3
      It depends on the thickness of the glass bed. When I started printing I used simple picture frame glass, which worked fine with the sensor as the glass was only 1.5mm thick.

      Later on I got proper borosilcate glass sheets and those where 3mm thick and the sensor failed to detect the aluminum bed underneath. You could get better results when using a metal sheet under the glass, but well ABL is not worth the trouble.

      Comment


      • #4
        I hear that, but [email protected] is using the Creality borosilicate glass plates on his Ender 5's & his EZABL is working. I'm suspicious this may be because of the way the EZABL works. I gather it is a little unusual by comparison.

        Comment


        • #5
          I have 5 EZABL sensors, 4 instated and 1 hot spare ( I like to be prepare). All are working on Creality glass beds. I have had them working with the plastic like fiberglass beds in the past.
          They do have an adjustment screw to set the sensitivity. I had the BLTouch on the Ender 5 Plus, but I keep jamming the probe and bending it, was only a matter of time before it broke.
          I'm also using the TH3D firmware for my Ender 5s and 5 Plus, based on Marlin 2. It has options that you can increase the probing speed of the Ezabl.
          Here is a video of it probing a 5 x 5 grid on an Ender 5. https://www.youtube.com/watch?v=qL6v...el=DavidWilson

          Comment


          • #6
            The information on the Th3dstudio says it will work with glass but needs to be calibrated when changing from one surface to another. The Ender 3 v2 comes with a glass bed, it has a black coating of some sort on one side but the back is glass. The not having the probe to get bent is a plus.

            I see that you have to compile the Unified2 code yourself. Been a loooooong time since I compiled any code. They tallk about using VSCODE to compile. That's a new one to me but like I said it's been a long time.

            Comment


            • #7
              I've done it quite a few times now. It's not hard.

              Comment


              • #8
                TH3D has an online compile for their Ezboard, which makes it really easy. I have 3 printers running on that board and 1 printer running on a SKR Mini E3 V2. I think they may have preconfilled firmware for that board. I asked for a couple of options, changes, which Tim H was not willing to provide in the stock firmware, so I had to learn how to make my own using Vscode. If you have ever done any programming it is fairly easy to use. I make sure to keep a backup of each compile and try to change only one thing at a time - then compile and test. Tim has a couple of videos on this subject and some good instructions on the TH3D website. https://www.youtube.com/watch?v=iE7d...nel=TH3DStudio

                Comment


                • #9
                  Originally posted by Gramps View Post
                  Currently have a Bltouch (genuine) and it shot craps today. Replaced the wiring and it still will not self test. It has been acting funky lately, failing when probing the bed. Considering I have to replace it I'm wondering if the EZABL is a better choice. Any experience here with both?
                  My BL Touch on my ender 3 v2 worked fine when i first got it for a while. Then it started failing test at first randomly then almost every time i turned the printer on or it probed the bed. At first thought it was the wiring so replaced it. Didn't do any good then replaced the bl touch. It worked pretty good for a few days then started failing also. After much searching on the internet and testing finally figured out that the hotend wires in the wiring harness was causing EMF interference with the bl touches signal wires. So went and bought this https://www.amazon.com/gp/product/B0...?ie=UTF8&psc=1 Ran the bl touch wires through it and soldered a wire to one end of the sleeve and attached the other end to the frame of the printer.

                  This not only fixed my probe failures but using the bed visualizer in octoprint i could tell the probe was a lot more accurate. I'm not saying this is your problem. You could will have a bad BL Touch. But it sure fixed my problems with the ABL.
                  Last edited by Larry; 02-24-2021, 08:32 PM.

                  Comment


                  • #10
                    Originally posted by Larry View Post

                    My BL Touch on my ender 3 v2 worked fine when i first got it for a while. Then it started failing test at first randomly then almost every time i turned the printer on or it probed the bed. At first thought it was the wiring so replaced it. Didn't do any good then replaced the bl touch. It worked pretty good for a few days then started failing also. After much searching on the internet and testing finally figured out that the hotend wires in the wiring harness was causing EMF interference with the bl touches signal wires. So went and bought this https://www.amazon.com/gp/product/B0...?ie=UTF8&psc=1 Ran the bl touch wires through it and soldered a wire to one end of the sleeve and attached the other end to the frame of the printer.

                    This not only fixed my probe failures but using the bed visualizer in octoprint i could tell the probe was a lot more accurate. I'm not saying this is your problem. You could will have a bad BL Touch. But it sure fixed my problems with the ABL.
                    You mentioned the the shielded cable in another post and I bought some and have the wires running through it and grounded. You are correct it did make a difference I didn't get near as many failures as before and bed visualizer looked much better. To test today I took another cable and ran it from the probe to the main board didn't follow the hotend wires and it still failed. I have noticed that it had started failing more and more the last week or so. For a while it might fail once in maybe a dozen prints or so and seemed to be worse upon initial startup. I'm pretty sure the probe has shot carps.

                    I downloaded VScode and installed it on my Linux Mint machine. Downloaded the Unified2 files for the E3v2 to see how hard it was going to be. When I loaded the configuration.h file to uncomment the version board I have I got an error about includes. Messed with it a little but got late and I stopped messing with it for the time being. Appears to be pretty easy once I get rid of the error.

                    Watched the video that Woodwaker_Dave recommended and saw they were getting the same error as I am. Looked at the Th3dstudio Vsciode installation guide and found that I didn't install the Programformio extension, think that might be my problem. I'll install it tomorrow and see.
                    Last edited by Gramps; 02-24-2021, 09:33 PM.

                    Comment


                    • #11
                      It sounds like your BLT electronics are slowly failing.

                      Comment


                      • #12
                        Originally posted by Ender5r View Post
                        It sounds like your BLT electronics are slowly failing.
                        I think they failed this afternoon when I was trying to start a print and couldn't get through the bed leveling process, then couldn't even get past the self test.

                        Comment


                        • #13
                          Went ahead and ordered the Ezabl Pro for Th3d Studio. Figure by the time it gets here I'll get Vscode running. Got it to compile but getting several no such directory errors. The directories are there so I'm thinking permissions issue.

                          Uninstalled Platformio and reinstalled it and was able to compile the Unified2 code.

                          After watching a couple of videos I think when I install the Ezabl I'm going to try a solid bed. I have some hard rubber spring replacements I'm going to try.
                          Last edited by Gramps; 02-25-2021, 02:55 PM.

                          Comment


                          • #14
                            I have an EZABL on a heavily modified Ender 5 running the unified firmware and a BLT on an Ender 3 V2 using Marlin 2.0 from https://marlin.crc.id.au/. They both work as advertised and I can not tell the difference in performance. I also have manufacturer-supplied ABLs on my Monoprice Ultimate 2 and my Anet ET5. I find the ability to adjust that ABL sensors with set screws for calibration of the sensitivity are easier to set up than when you have to physically move the sensor up and down. So this gives the EZABL and Anet ET5 sensors an advantage from my point of view.

                            The ANET ET5 uses a glass bed with a Buildtak style sticker on top. This works fine with the ANET sensor which is not a physical sensor. I cannot find definitive information on if it is inductive or capacitive.

                            Comment


                            • #15
                              The Ezabl arrived today. I installed it on my Ender 3 v2. Following the directions on TH3D it was pretty straight forward. I did however have a couple of hiccups. I opted to power it off the printer power supply and the wire for this that came with the Ezabl kit in my opinion was total junk. Looks like 2 solid wire telephone wire to me. It kept breaking where it came out of the jacket. After this happening twice I decided to go with some good 20g silicone wire. I ran it through some of the mess wire covering that I had on hand to help protect it running through the frame. The next issue is setting the Z offset. You can set it using the menu but it doesn't change it live so it turned out to be a guessing game, which I wasn't very good at. According to Tim at TH3D the LCD on the Ender 3 v2 is junk. It doesn't have open source firmware on it so it's hard to program. His suggestion is to use the LCD from the Ender 3 which is $18. Then compile the firmware as Ender 3 and there will be many more menu options. I knew this might be a problem going in so yesterday I ordered on that should be here tomorrow. I can hook it up and reflash making it much easier to set the Z offset. As far as probing goes haven't had a hiccup yet, knock on wood, can't say the same for the Bltouch I had.

                              Compiling the firmware is really a walk in the park once you get VSCode setup and working. Tim has made it real simple, you uncomment the printer that you are using such as Ender 3, TMC2208 stepper drivers, EZABL mount you used and compile. That's it your done except for copying it to your SD card and flashing the printer. You can also use this firmware without having a Ezabl too just don't uncomment the mount.

                              I'm trying something different. I removed the springs from my bed and replaced then with some 3/4" brass bushings I got at the hardware store. I have nuts on the screws so I didn't have to worry about the tubes messing with the heating circuit. I checked and the height of all 4 corners is with in .5mm which should be close enough for the abl sensor to handle. Only time will tell if this was a good idea or not.

                              Comment

                              Working...
                              X