Announcement

Collapse
No announcement yet.

Cura not combining .stl together properly.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Cura not combining .stl together properly.

    I used Tinkercad to import and connect 2 .stl files.(export whole as .stl) No problem in Tinkercad but when i open in Cura I have different results from prepare view and preview. Since I have a large bed Ender5+ I was hoping to combine many files like this in the future. When I go to print it leaves the notch as you in the right. I really cannot move the pieces closer since the slides slope and would make the edges not smooth (ie it would show in the print.)
    1st image during mid print w unwanted notch 2nd Red image is grouped object closeup in Tinkercad, 3rd yellow in Cura. Any advice or outside reference would be appreciated. thank you.Click image for larger version

Name:	midprint.PNG
Views:	22
Size:	317.1 KB
ID:	7609Click image for larger version

Name:	tinkerCloseUp.PNG
Views:	24
Size:	90.2 KB
ID:	7608Click image for larger version

Name:	curaPreparevsPreview.PNG
Views:	332
Size:	1.12 MB
ID:	7607

  • #2
    I guess your position is off by a fraction of a millimetre and FreeCAD is dealing with them as two objects.

    You also should use the part workbenchs menu item "create a copy->refine shape". That way FreeCAD is simplifying a model removing lines and faces on the inside. In your case the parallel/overlapping/connected lines/faces on the inside will build a proper bigger block instead. This should also shows if the blocks are really connected within FreeCAD. If you change the view to wireframe or hover over it (0.19 object turns transparent), the lines where it was connected should vanish.

    Export this new element to get a proper and re-enforced print as the layer lines are now get trough both parts as well as the infill.

    Just a small tip for people using FreeCADs PartDesign. If your design is done, select the last pad/pocket (not sketch!) and use "create a copy->refine shape" from part workbenchs specific menu. Export that copy. It will create a model that is smaller, far easier to slice as e.g. lines on the inside are gone and depending on the slicer prints faster. If you want to change a model afterwards you need to delete the copy or FreeCAD will annoy you with "out of scope" errors and may or may not update the copy object. Just delete it and once changes are done, create a copy and export that copy.
    Last edited by Geit; 01-10-2021, 05:56 AM.

    Comment


    • Ender5r
      Ender5r commented
      Editing a comment
      Not sure how much it matters, but the OP said he's using TinkerCAD.

    • Geit
      Geit commented
      Editing a comment
      Yeah, I donĀ“t know why this happened. I was sure I read Cura and FreeCAD

    • Ender5r
      Ender5r commented
      Editing a comment
      Regardless, I think the principles are the same. It would be the details specific to TCAD that would differ.

  • #3
    As Geit noted, it looks like there is enough of a gap so that Cura isn't printing that area. Are you using align parts feature in TinkerCAD to move the two STL's together?

    Cheers

    Comment


    • #4
      You are correct, the 2 pieces were very slight separated though it didn't appear so even when viewed from the inside out.
      I do use the align tool but not sure how i can get the edges to meet exactly. I can align in the X and Y directions but don't know how to make sure they butt together without "overlap" as I did visually here. Aligning in the 3rd dimension overlap the whole object.

      Thank you all for your excellent replies. I plan to move to / learn FreeCad soon.

      Comment


      • #5
        Are the joining surfaces parallel? If so, try setting one as the working plane.

        Cheers

        Comment

        Working...
        X