Announcement

Collapse
No announcement yet.

Octoprint issues

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Octoprint issues

    Hello all
    I watched your setup for Octopint and it worked great as far as getting it setup and seeing the printer. The issue I was having was it was not printing on the print bed. It would start printing off the print bed. I checked all the setting and they are right for the printer bed. I was looking for some answers to why that would be.
    When I want back to work on the issue I have a new problem.
    When I log into Octoprint and it try to connect I get an "Off Line" message, I have reset everything and still nothing. I know the IP address is good because I can see the camera just fine.
    I didn't make any changes to the setup.
    The only thing that seems to have change was when I logged in I got a new version update and it did the update.
    Not sure if that is the issue or not.
    Any thing will be a big help.
    Thanks
    Marc

  • #2

    OctoPrint does not change the position of prints on your printer. I guess it could if there is a plug-in, but naturally it just pipes the gcode file from its SD card via USB to the printer. So if your print misses the build plate, then it is the slicer to blame. In specific the slicer configuration.

    However you need to setup OctoPrint as it checks if the print fits the build plate. If your print bed size is set up wrongly in OctoPrint you may get an error "object to big for build volume".
    This is just a warning, shows up only once and you can ignore it and push print again.

    The OctoPrint server seems to go into some kind of sleep mode after some time. This is just a guess, but it happens that you log in and it shows "offline". This doesn´t mean you need to reset everything. Just click reload on your browser and it will pop up. It also sometime claims to be offline within the login screen. Just ignore that.

    The slower the PI is the longer you need to wait. There is no need to reset the PI, the printer your your computer. I have three instances of OctoPrint running on three Pis (Pi1, Pi2 and Pi3) and they all show this behaviour. Just reload and try again. I never reset any of them and they run 24/7. I consider this strange behaviour as a bug in OctoPrint as it clearly lies about its actual state.

    Also when the interface appears it takes a few seconds to be really responsive. If you have plugins installed that add icons to the top screens toolbar, you even see dummy images during that period. Once OctoPrint got loaded, it works just fine. I have no clue why that behaviour did not get changed/fixed, as it is very confusion on occasion.

    Also keep in mind that OctoPrint is using JavaScript, which needs a ton of CPU on your computer while loading. So If you try a phone or a tablet with less power, give it some additional time to sort the initial loading out.
    Last edited by Geit; 08-11-2020, 11:03 AM. Reason: less typos, rewording

    Comment


    • #3
      Hi Marc,

      It sounds like you have two problems. One with the printer and one with Octoprint. What printer are you using? How did you level and adjust Z-offset?

      Regarding OctoPrint, are you saying you were able to connect to the printer but hitting the "Connect" button fails ("Offline (Error: No more candidates to test, and no working port/baudrate combination detected.)")? What procedure do you use to reset the Raspberry Pi?

      Sorry for all the questions. i setup using DRVAX's video and have not had any problems.

      Cheers

      Edit: After seeing Geit's post above, does the Pi have it's own power source?
      Last edited by Alan; 08-11-2020, 10:43 AM.

      Comment


      • #4
        Originally posted by Alan View Post

        ("Offline (Error: No more candidates to test, and no working port/baudrate combination detected.)")
        Right. Thisis another annoying one, which comes into play on certain printer firmwares. If you setup the connection to "Auto" it tries to connect using all baud rates. When it finds the correct one, it starts. However, when you go offline and online again, depending on your printers firmware this isn´t working, even with the correct baud rate preset. You need to set auto again and push connect. Configuring the baudrate to 500000 does not work at all.

        I can only assume this is releated to some old marlin. 500000 is also a very odd default baud rate for a serial interface and a non standard value which makes no sense. I have that on my TronXY with original marlin 1 firmware, but when using my own printer, where I set up a standard baud rate I can reconnect in auto mode as well as pre set a baud rate.

        Comment


        • #5
          500000 is truly a very odd BAUD rate. I have done a TON TON TON of serial work over the decades (I still have a breakout box somewhere), and I have never seen anything use that rate. Besides, BAUD rates are supposed to be powers of 2, so it should be 524,288.

          Comment


          • #6
            Thanks for the info Guys.
            I will give everything a try. I want to get my Octoprint running before I worry about the print issue. I will let you know what I find.
            Thanks
            Marc

            Comment


            • #7
              Gave it another try and getting the same issue. After hitting connect it waits a bit the shows off line. I'm using Raspberry Pi 3. I has the power supply that came in the kit.
              I have tired setting the Baud rate to Auto and same issue. I upgraded the Marlin to the latest version.
              The only thing that as changed from when It worked from now is an update to the Octoprint software. Is there a way to roll it back to before the update?
              Thanks

              Comment


              • #8
                All I would do in your case it switching the 250000 to auto and hit connect. Well, assuming the printer is already powered up for a few seconds.

                The "auto connect on server start" is kind of useless unless you power up the printer and the pi together. It just means the pi is trying to connect to the printer after booting up.

                If you have power for both separated and leave the pi on, than you need to press the connect button and if the browser was opened before you need to re-change the baudrate to auto before doing so. Make sure you only press the connect button a single time. It will turn into a disconnect button, which the second click will trigger. Another stupid design choice.

                It has nothing to do with the version of OctoPrint. I updated to the latest, too. Check the connectivity settings and the baud rate specified there. Put "auto detect" in there and disable the auto connect. Actually I don´t understand why OctoPrint isn´t performing a retry on its own. It could try the defined baud rate and auto in a loop and the connect button could be removed. There is nothing you can do anyway, while it is not connected beside uploading files.

                If nothing helps, check the USB cable and maybe swap the usb port on the PI. Beside that a preset value may not work I never had a real issues getting it to work.

                Comment


                • #9
                  That's good the Pi has its own power supply. If what Geit recommends above doesn't work, go to the terminal tab, Clear all, hit Connect, and post the lines after "Changing monitoring state from "Offline" to "Detecting serial connection" (below is what OctoPrint shows after a successful connection). Note: my instance is connecting at a baudrate of 115200.

                  I'm wondering if the OctoPrint instance is corrupt and might need to be re-installed from scratch.

                  Cheers

                  <begin text from Terminal tab>
                  Changing monitoring state from "Offline" to "Detecting serial connection"
                  Performing autodetection with 7 port/baudrate candidates: /dev/[email protected], /dev/[email protected], /dev/[email protected], /dev/ttyACM[email protected], /dev/[email protected], /dev/[email protected], /dev/[email protected]
                  Trying port /dev/ttyACM0, baudrate 115200
                  Connecting to port /dev/ttyACM0, baudrate 115200
                  Handshake attempt #1 with timeout 2.0s
                  Connected to: Serial<id=0x7292b370, open=True>(port='/dev/ttyACM0', baudrate=115200, bytesize=8, parity='N', stopbits=1, timeout=2.0, xonxoff=False, rtscts=False, dsrdtr=False), starting monitor
                  Send: N0 M110 N0*125
                  Recv: echo:Unknown command: ""
                  Recv: ok P7 B5
                  Changing monitoring state from "Detecting serial connection" to "Operational"
                  Recv: ok N0 P7 B5
                  Send: N0 M110 N0*125
                  Recv: ok N0 P7 B5
                  ...

                  Comment


                  • #10
                    MarcSchuh Any progress?

                    Comment


                    • MarcSchuh
                      MarcSchuh commented
                      Editing a comment
                      Not yet, I got busy with a few projects and my new Ender # V2

                  • #11
                    Geit Alan I want to repeat Geit's suggestion about checking the cable. Not all USB cables are the same. Some of them include both the power pins and the data pins and some do not. I recommend trying a USB cable that specifically lists support for charging and data. Here is a very good explanation I found on the web:

                    https://www.dignited.com/50330/usb-d...harging-cable/

                    Comment


                    • MarcSchuh
                      MarcSchuh commented
                      Editing a comment
                      I will give it a look. The cable I used was working but I don't recall were I got it.
                  Working...
                  X