Announcement

Collapse
No announcement yet.

Ender 3 x axis not level

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Ender 3 x axis not level

    I just put a new ender 3 together but the x axis is not level. When facing the printer the left side is lower. I can grip both ends to level it up but as soon as I release the problem returns

    Click image for larger version

Name:	5F0A73D1-0E52-4B65-A10A-CD95304EE7B6.jpeg
Views:	45
Size:	2.51 MB
ID:	2234
    Attached Files

  • #2
    Could the bed be the problem?

    Comment


    • Mac-7
      Mac-7 commented
      Editing a comment
      Anything is possible. I leveled the fame as recommended. But I dont see any adjustment that would even up the x axis

  • #3
    Measure the bridge against the bottom frame. For example get a small rectangular object like an usb stick, a kids toy cube or a simple block you printed for this task before. If possible get two exact similar ones.

    Turn off the printer. Place the measurement objects on the bottom base frame below the bridge. Now lower the bridge by hand until it sits on the object of your choice. Check the other side with the same object. Do not use the base of the table as foundation. Make sure you use the aluminum base of the printer itself.

    If you notice any difference you need to loosen the Z rods/belts on both sides, so it "falls" onto your measurement objects. This is the main point, where two measurement objects of the same size come in handy. You need to do this on both sides. This is the only way to align the bridge as it may (depending on the construction) next to impossible to move one side without the other. Especially when both sides of the bridge have a belt between them.

    Tight everything up again and the axis is calibrated. Power up the printer and drive the Z axis up and down and check again using your measurement objects if it stays level when reaching the measurement objects hight. If it does your steppers are working fine. When it is not, one of your stepper motors is probably broken.

    Now try at a different height to see of one stepper is moving more than the other. Here you just can use a ruler. Power the printer up, drive the Z axis 15cm up and check if both sides are still the same. If one side is higher, then you have a problem with the e-step configuration or the stepper driver itself.

    This means that e.g. the right stepper is moving for example 2/32 of a rotation per step while the left one is doing only 1/32 of a rotation, which causes the height difference when raising the bridge.

    A broken stepper should itself get visible when driving the printer up and back onto the measurement objects, while a wrong e-step would cause the bridge to be perfectly landing on your measurement objects, but being more and more misaligned when raised higher and higher.

    Hope this gives you some insight to find out the cause of your problems.

    Comment


    • #4
      When you say the bridge what is that?

      Comment


      • #5
        Is there a video that demonstrates that proceedure? I have not printed any object with this printer yet

        Comment


        • #6
          Originally posted by Mac-7 View Post
          When you say the bridge what is that?
          The horizontal beam where the X carriage/print head is mounted to and which is moving up and down. On this kind of printer it is often referred as a bridge.

          There are probably videos on this topic on youtube. Search for "ender gantry setup" or "ender z calibration" or so.

          Your situation is exactly why I don´t like these printers to be called "perfect for beginners". Yes, usually you unbox them, put in some screws and it works out of the box, but when you run into a problem you have no clue where to start searching for the source of it.

          A friend of mine had a similar issue with his Ender printer. It worked fine until it didn´t and then he got frustrated because of the sticking in the dark. In my opinion these kits from china are the best to get started. Once you have assembled them you know every part of the machine and already learned the basics from leveling the x gantry to properly changing a nozzle. It was the nozzle part my friend got trapped in. After replacing the nozzle, the printer started clogging and he did not know why. He simply never did that before and did it wrong. With a kit you do everything at least once and you usually have a video showing everything in detail, so later on you know how to fix issues. My friend sold his printer later on even so he managed to fix the issue after my advice.

          The reason I tell you this is not to get frustrated by this issue or to blame you on buying the "wrong" printer. I just want to ensure you that there are plenty of ways to get any issues resolved. You just got caught with the frustration side before you even got the chance to experience the joy of making something.

          You would have had this issue anyway even if the printer worked out of the box. Just much later. A single failed print where the print head crashes into the print could have caused exactly this issue, too.
          Last edited by Geit; 07-31-2020, 06:50 AM.

          Comment


          • #7
            This means that e.g. the right stepper is moving for example 2/32 of a rotation per step while the left one is doing only 1/32 of a rotation, which causes the height difference when raising the bridge.

            now I am confused again. There is no left and right stepper motor on the x axis. Just one stepper on the left when facing the ender 3 if I understand you correctly

            Comment


            • #8
              Originally posted by Geit View Post

              The horizontal beam where the X carriage/print head is mounted to and which is moving up and down. On this kind of printer it is often referred as a bridge.
              Ok thanks. Thats what I was hopping you meant

              but there is only one stepper on the ender 3

              Comment


              • #9
                Originally posted by Mac-7 View Post

                Ok thanks. Thats what I was hopping you meant

                but there is only one stepper on the ender 3
                Well, I did not know that. I never saw an Ender in real live

                In that case it probably got shaken up during transport.

                So I assume it has a belt going from the Z stepper side to the other side?

                Even if not you should ensure the vertical beams are mounted in a 90° angle.

                This seems to be a good guide of doing the assembly. Even so you already did that it may be helpful to see it from another perspective and catch something you did different:

                https://letsprint3d.net/how-to-assem...ality-ender-3/

                It appears that there is just one lead screw, so you probably have a problem with the tension of the wheels on the other side causing the bridge to sack down on the non stepper side.
                Last edited by Geit; 07-31-2020, 07:03 AM.

                Comment


                • #10
                  https://www.youtube.com/watch?v=X6cqQZTc-4Q Chuck on the CHEP YT site discusses this in this video.

                  Comment


                  • #11
                    Thanks roon4660,

                    at 5:41 the video talks equalizing the distance between the two horizontal bars. As soon as I can I will try that.

                    Comment


                    • #12
                      Yeah, CHEP's video is a good one. Getting a printer squared up is vital to getting good prints. Which reminds me, time to check my own printer again...as soon as the current print is finished...

                      Comment


                      • #13
                        I’m looking forward to my first print as soon as I am sure the printer is set up correctly

                        Comment


                        • #14
                          I found the problem and it was so simple. The 2020 x-axis holding the extruder was level after all. It was the fan housing that was crooked.

                          thanks for all the helpful suggestions

                          Comment


                          • #15
                            YW. Your experience just proves the old adage: if all else fails, go back to the basics.

                            Question: does the fan housing being crooked also mean the hotend was crooked?
                            Last edited by Ender5r; 08-01-2020, 07:04 PM.

                            Comment

                            Working...
                            X