Announcement

Collapse
No announcement yet.

Z Axis stopped moving

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Z Axis stopped moving

    9 month old Kingroon printer may be inexpensive but has made beautiful PLA objects. Today the Z axis stopped moving during a print. Now Z axis won't move using Z move up/down buttons. Z axis also doesn't move (home) when using assisted bed leveling. Power is reaching the Z axis stepper motor because it resists manual movement when the printer is turned on (very little resistance when turned off like normally). Move screen reports Z= -180 after trying to use assisted leveling (X and Y home but Z doesn't move). Clicking the Z axis end stop switch results in Z = 0 display but doesn't fix Z movement issue. Ideas?

  • #2
    OK, one crazy idea. How 'bout swapping data cables: say, swap the X and Z axis. Then, use Pronterface (or similar) to send something like G1 X50; see if the Z axis moves.

    Comment


    • #3
      Swapping Z and Y cables moves the Z axis but not the Y so it's not the Z axis stepper motor or mechanicals.Can the driver fail so stepper gets power on but doesn't move?

      Comment


      • #4
        The begins to narrow down the choices I think:
        1. faulty cable: perhaps one of the pins is bent or pushed back in the connector.
        2. connection to the motherboard: perhaps the connector has come loose from the motherboard, or the connections have become corroded.
        3. faulty hardware driver: perhaps the stepper motor driver has failed. This likely would require replacement of the motherboard.

        Comment


        • #5
          MKS Robin MINI STM32 A4988 RAM 32bit Robin Controller Motherboard is used in the KP3. It has socketed drivers according to aliexpress. I haven't looked at board yet so we'll see what is actually in there tomorrow. I'll ensure the fan is running to cool the drivers. Never had a driver fail before. I guess the trim pot will need to be adjusted too. Sigh...

          Comment


          • #6
            It's certainly not a guarantee that the stepper driver is dead; just a more likely option that it was before, since you've eliminated the stepper motor. The Y axis on my brand new Ender 5 would stop working randomly in the middle of a print. In my case it turned out to be the firmware, if you can believe it. Since your printer has been working well for quite a while, I think firmware is an unlikely culprit. That said, it couldn't hurt to reflash it, just in case.
            .
            It's certainly a lucky break that the stepper drivers are socketed. However, over the decades, I have learned 3 rules of electronic troubleshooting: connections, connections, connections. I say that because it's possible, just possible, that pulling the stepper driver chip, and re-seating it, preferably several times, will restore the connectivity to its original state. While you're in there, you might as well re-seat all of the socketed chips.
            .
            Whether or not the original fan is dead, it would be an idea to replace it with a newer, more powerful, quieter one. Fans are cheap by comparison to most other components, so it makes sense to use good ones.
            .
            I'm surprised to hear that there's a trim pot. Are you referring to one on the mobo?

            Comment


            • #7
              Disassembly this afternoon. Checked and fan is working - actually very quiet. Good suggestion on re-socketing I'll definitely do that.Way quicker than ordering new drivers. I'll use contact cleaner if they look suspicious.

              Comment


              • #8
                Originally posted by PsyPhyGuy View Post
                I'll use contact cleaner if they look suspicious.
                I generally find that unsocketing, then re-socketing, doing that 3 to 4 times is the best technique. It scraps any oxidation off the pins and sockets. A white plastic eraser (NOT the pink ones on the end of pencils) also can help, but the physical resocketing virtually always works for me.

                Comment


                • #9
                  Took the cover off. The drivers are down on the board and share a heat sink. Swapped Z and Y wiring at the board (this tests the cabling) Y stopped working X started working.
                  So, the failure must be the driver.
                  The mother board is toast. Did find it's possible to wire in an "external" driver (https://www.youtube.com/watch?v=UejSUgvbUgE) but what a kludge. The MKS Robin Mini v2 board is no longer manufactured so a direct swap isn't available. No interest in buying a board without replaceable drivers anyway.
                  Loved this machine and the touchscreen UI but can no longer recommend the Kingroon.
                  Wondering if I should just buy a new 3D printer and toss this one on the broken dreams pile in the basement or try to kludge it.
                  Think I'll have a beer.

                  Comment


                  • #10
                    I was afraid of that. Re: a new printer: you might want to look at the ADIMLab Gantry Pro (https://www.amazon.com/ADIMLab-Assem...s%2C158&sr=8-1. From what I've seen & read, it offers a lot for the money.

                    The one main complaint I've heard is the gantry could be a little unstable with huge prints, but users have pretty easily fixed that with some bracing.

                    Comment


                    • #11
                      Maybe you can find a used board on e-bay!?

                      Comment


                      • #12
                        Aliexpress: https://www.aliexpress.com/item/4000926079669.html replacement mobo
                        Now just wait until mod August...

                        Comment


                        • #13
                          That is a really good price for a 32-bit board. Not sure which stepper drivers it has, but they do have heat sinks, which is not great, but it is common. It seems to have all the sensor inputs & pwr outputs you could want. I hope you ordered 2.

                          Comment


                          • #14
                            Originally posted by PsyPhyGuy View Post
                            Aliexpress: https://www.aliexpress.com/item/4000926079669.html replacement mobo
                            Now just wait until mod August...
                            Good luck! I ordered some printer parts from AliExpress on 6/25. As of 7/1 the order "departed country or origin." Fingers crossed.

                            Cheers
                            Last edited by Alan; 07-03-2020, 04:06 PM.

                            Comment


                            • #15
                              Yeah. North American vendors are having a tough time getting goods from China these days.

                              Comment

                              Working...
                              X